Ubuntu 에서 Eclipse Android 설치중 문제

Eclipse 는 Galileo 입니다. JDK 는 1.6.0.21(맞나, 어쨌든) 사용하고요.
안드로이드를 설치하려고 합니다.
Help-Install new Software 에서

http://dl-ssl.google.com/android/eclipse 로 경로 설정을 받은 후 다운로드 와 설치는 다 되나 끝나갈때쯤에 아래와 같은 화면이 나타나면서 안됩니다. [ 스크린샷-1.png ][attachment=0:3joy7v2u]스크린샷-1.png[/attachment:3joy7v2u]

(여기까지는 됩니다. [스크린샷.png] [attachment=1:3joy7v2u]스크린샷.png[/attachment:3joy7v2u]
그리고 자세한 에러 메세지는 다음과 같습니다.
An error occurred while uninstalling
session context was:(profile=SDKProfile, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Uninstall, operand=[R]org.eclipse.equinox.concurrent 1.0.0.v20090520-1800 –> [R]org.eclipse.equinox.concurrent 1.0.1.R35x_v20100209, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.UninstallBundleAction).
Error while loading manipulator.
Error while loading manipulator.
어떻게 해야되는지 알려주시면 감사하겠습니다.