Vsftp 관련 질문입니다

본사에 우분투 서버 8.10 을 설치하였습니다.

서버는 LAMP, SSH, VSFTP 설치하였구요

본사에서 할때는 SSH 접속, FTP 접속이 잘 되었습니다.

(SSH는 PUTTY, FTP는 알 FTP를 사용하여 잘되는것을 확인하였습니다.)

지금 다른곳에와서 접속을 해보니 SSH접속은 잘 되는데 FTP만 유독 접속이 안됩니다.

socket error #10054라는 에러가 나오면서 접속이 안되네요…ㅠㅠ


접속하시는 클라(ftp 프로그램)에 passive on 하고

서버 /etc/vaftpd.conf 파일 끝에

Active Mode ( = YES)

를 넣어 보시기 바랍니다.
보통 ftp 프로그램중에 패시브 모드를 헛갈리는 어플들이 있습니다.

/etc/vsftpd.conf 위같이 수정하고… 데몬 재시작 후

알ftp와 cuteftp에서 패시브모드로 접속해보았으나…

아직도 접속이 안되네요…ㅠㅠ

문제가 뭘까요…ㅠㅠ

[quote="icebrain":2h6rljqa]알ftp와 cuteftp에서 패시브모드로 접속해보았으나…

아직도 접속이 안되네요…ㅠㅠ[/quote:2h6rljqa]

패시브모드 오토로 해보십시요

socket error #10054 메세지는 접속유지 중 끊는 메세지 이나
우분투 vsftp 사용자 분들은 모드 때문에 조금 고생하는 분들이 있더군요

그래도 안된다면 ftp 서버 아이피와 아이디 비번을 쪽지로 주시기 바랍니다.
제가 접속 상태 점검만 해보지요

I have had this problem before, where cuteFTP (and some other FTP programs) would send part of a file up to the server and then just stop with a socket error 10054 or other error.

There IS a way to solve this however, and it has to do with the SEND BUFFER setting in your FTP program.

In Cute FTP (later versions) the SEND BUFFER default is set to 64K - this is WAY to high in my opinion.

Change the SEND BUFFER to 2K and then connect again and try your transfers… They will work for sure :-)

Two solutions regarding this socket error 10054:

Solution 1: Is already mentioned by most which uses PASV to listen to the data port. Commonly this should resolve most issues regarding this socket error.

Solution 2: For weird cases, like what I’ve encountered using EPSV instead of PASV should provide the ability to have the server specify an IP v6 address back to the client. Basically this waits for the server to respond or hangs around until the server will respond unlike the normal passive mode which may quit when it gets tired of waiting for a response.

EPSV : Extensive Passive : requests that a server listen on a data port and wait for a connection. The EPSV command takes an optional argument. The response to this command includes only the TCP port number of the listening connection.