12.04 듀얼모니터 사용중 부팅시 vga 출력만 정상 해상도가 안잡힘

인텔 i5 내장 그래픽이며 Q67 칩셋보드에 12.04 32비트 설치 사용중입니다.

메인보드에서 HDMI, VGA 출력을 지원하고 있으며 현재 모니터는 듀얼로 연결되어 있고 HDMI 연결된 모니터는 정상적으로 해상도 문제없이 잘 나오고 있으나
VGA 단자로 연결된 19인치 모니터는 1024768로만 잡혀서 xrandr로 12801024 해상도 모드를 추가하여 설정했습니다.
설정된 내용은 rc.local에 잘 저장하고 부팅하면 두 화면 모두 기본해상도로 풀려있고 클론모드로 동작합니다.

[attachment=1:3utq7fcm]20130716_211243.jpg[/attachment:3utq7fcm]
[attachment=0:3utq7fcm]20130716_211250.jpg[/attachment:3utq7fcm]

일단 부팅후 콘솔에서 rc.local를 강제로 실행하면 다시 HDMI도 정상적으로 VGA도 1280*1024로 돌아옵니다.

rc.local 내용은 다음과 같습니다.

xrandr --newmode "1280x1024_60.00" 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsync
xrandr --addmode VGA1 "1280x1024_60.00"
xrandr --output VGA1 --mode "1280x1024_60.00" --right-of HDMI1
exit 0

저랑 똑같은 문제로 고민하시는군요…
제 놋북에 24인치 모니터를 d-sub 케이블로 연결후 해상도 조정을 하려면 1024*768 이 최고
해상도 라서 xrandr 스크립트 명령어를 만들어서 부팅후 실행을 해 줘야지만 해상도가
정상적으로 표시되었었는데…
지금은 우연치 않은 일을 하다가 해결 되었습니다.(해상도가 다 표시됨)
케이블을 바꾸니 해상도가 정상적으로 동작 되더군요… 원래 케이블을 연결하면
똑같은 증상이 나타나고요…

1년동안 써 오면서 귀찮았었는데… d-sub 케이블 문제일줄이야…
(근데 윈도우에서는 원래 케이블도 정상 작동 되었습니다.)
d-sub 케이블 얼마 안하니 속는셈 치고 한번 도전해 보세요.

아 한가지 빼 먹었네요… d-sub 케이블이 제가 쓰고 있는 24인치 모델에서만
증상이 나타나고 다른 모니터에서는 정상적으로 작동 했습니다.
모니터를 몇가지 붙혀봐도 정상적으로 해상도를 표시해 주는데
제 24인치 모니터에서만 그런 증상이 나타나더군요…

케이블 교체하고 현재는 이상없이 잘 사용하고 있습니다.
제가 사용했던 스크립트 명령어 이엿습니다
#!/bin/bash
xrandr --newmode "1280x1024_60.00" 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsync
xrandr --addmode VGA1 "1280x1024_60.00"

xrandr --newmode "1920x1200_60.00" 193.25 1920 2056 2256 2592 1200 1203 1209 1245 -hsync +vsync
xrandr --addmode VGA1 "1920x1200_60.00"

[quote="mediann":3uxlk8oz]저랑 똑같은 문제로 고민하시는군요…
제 놋북에 24인치 모니터를 d-sub 케이블로 연결후 해상도 조정을 하려면 1024*768 이 최고
해상도 라서 xrandr 스크립트 명령어를 만들어서 부팅후 실행을 해 줘야지만 해상도가
정상적으로 표시되었었는데…
지금은 우연치 않은 일을 하다가 해결 되었습니다.(해상도가 다 표시됨)
케이블을 바꾸니 해상도가 정상적으로 동작 되더군요… 원래 케이블을 연결하면
똑같은 증상이 나타나고요…

1년동안 써 오면서 귀찮았었는데… d-sub 케이블 문제일줄이야…
(근데 윈도우에서는 원래 케이블도 정상 작동 되었습니다.)
d-sub 케이블 얼마 안하니 속는셈 치고 한번 도전해 보세요.

아 한가지 빼 먹었네요… d-sub 케이블이 제가 쓰고 있는 24인치 모델에서만
증상이 나타나고 다른 모니터에서는 정상적으로 작동 했습니다.
모니터를 몇가지 붙혀봐도 정상적으로 해상도를 표시해 주는데
제 24인치 모니터에서만 그런 증상이 나타나더군요…

케이블 교체하고 현재는 이상없이 잘 사용하고 있습니다.
제가 사용했던 스크립트 명령어 이엿습니다
#!/bin/bash
xrandr --newmode "1280x1024_60.00" 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsync
xrandr --addmode VGA1 "1280x1024_60.00"

xrandr --newmode "1920x1200_60.00" 193.25 1920 2056 2256 2592 1200 1203 1209 1245 -hsync +vsync
xrandr --addmode VGA1 "1920x1200_60.00"[/quote:3uxlk8oz]

답변 고맙습니다. 케이블 교체는 아직 못해봤는데 한번 시도해봐야 겠네요.
부팅시 에러나는게 어딘가 꼬인게 아닌가… 아님 순서가 잘못됐거나 싶은데…
일단 부팅이 완료되면 rc.local 강제로 실행하면 되는걸로 봐서 하드웨어 문제는 아닌것 같고요…

[quote="wizardoozz":rsrnuw5e][quote="mediann":rsrnuw5e]저랑 똑같은 문제로 고민하시는군요…
제 놋북에 24인치 모니터를 d-sub 케이블로 연결후 해상도 조정을 하려면 1024*768 이 최고
해상도 라서 xrandr 스크립트 명령어를 만들어서 부팅후 실행을 해 줘야지만 해상도가
정상적으로 표시되었었는데…
지금은 우연치 않은 일을 하다가 해결 되었습니다.(해상도가 다 표시됨)
케이블을 바꾸니 해상도가 정상적으로 동작 되더군요… 원래 케이블을 연결하면
똑같은 증상이 나타나고요…

1년동안 써 오면서 귀찮았었는데… d-sub 케이블 문제일줄이야…
(근데 윈도우에서는 원래 케이블도 정상 작동 되었습니다.)
d-sub 케이블 얼마 안하니 속는셈 치고 한번 도전해 보세요.

아 한가지 빼 먹었네요… d-sub 케이블이 제가 쓰고 있는 24인치 모델에서만
증상이 나타나고 다른 모니터에서는 정상적으로 작동 했습니다.
모니터를 몇가지 붙혀봐도 정상적으로 해상도를 표시해 주는데
제 24인치 모니터에서만 그런 증상이 나타나더군요…

케이블 교체하고 현재는 이상없이 잘 사용하고 있습니다.
제가 사용했던 스크립트 명령어 이엿습니다
#!/bin/bash
xrandr --newmode "1280x1024_60.00" 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsync
xrandr --addmode VGA1 "1280x1024_60.00"

xrandr --newmode "1920x1200_60.00" 193.25 1920 2056 2256 2592 1200 1203 1209 1245 -hsync +vsync
xrandr --addmode VGA1 "1920x1200_60.00"[/quote:rsrnuw5e]

답변 고맙습니다. 케이블 교체는 아직 못해봤는데 한번 시도해봐야 겠네요.
부팅시 에러나는게 어딘가 꼬인게 아닌가… 아님 순서가 잘못됐거나 싶은데…
일단 부팅이 완료되면 rc.local 강제로 실행하면 되는걸로 봐서 하드웨어 문제는 아닌것 같고요…[/quote:rsrnuw5e]

===============================================================================
저도 부팅을 하면 CRTC 에러 메세지가 똑같이 나왔었습니다…
듀얼 모니터 사용시 듀얼 모니터로 설정 하고 재 부팅을 하면 CRTC 에러 나오면서 화면 복제로
되돌아 가고 XRANDR 쉘 스크립트 를 만들어서 실행해 주면 다시 듀얼 모니터로 설정 되고 했거든요…

이거 해결하게된 이유가 책상에 먼지가 많이 쌓여서 다 들어내고 청소한 다음
모니터 케이블이 많이 지져분해져 있어서 다른 케이블로 연결하니 바로 해결되버리더군요…

ㅎㅎ… 제가 생각하기에는 소프트웨어적인 문제는 아닌걸로 보입니다…
다른 모니터 들은 자기 해상도및 재 부팅시 CRTC 에러가 나지 않고 자기 해상도를 다 표현해 주었거든요
모쪼록 잘 해결되길 바랍니다…