[해결됨] 우분투 9.10에서 네트워크상의 윈도우 공유폴더명 깨짐문제

우분투 9.10 Beta와 RC버전에서도 동일한 증상이었으나,
정식버전에 해결될 줄 알고 기다렸었습니다.
그런데… ㅠㅠ

[attachment=0:3zrsumow]Ubuntu_9.10_samba_winshare.png[/attachment:3zrsumow]

우분투 9.10 버전에서 노틸러스를 실행하고 Ctrl + L 위치정보에
smb:// 192.168.10.101을 입력하여 삼바공유로 윈도우XP의 공유폴더로 접근하였더니
위와 같이 한글이 깨져 나옵니다.
영문폴더는 문제없이 마운트 되지만, 한글은 깨져서 그런지 마운트조차 안됩니다.
처음에 VirtualBox에서 실행해서 그런가 했는데, USB에 9.10을 넣고 라이브로 부팅해 봐도 마찬가지입니다.
또한 설치 직후나 라이브 상태에서 한글언어팩을 업데이트해도 해결이 되지 않았습니다.
혹시 공유기 특성을 타나 싶어서 다른 네트워크에서 테스트 해 봤는데
그 곳에서는 아예 공유된 한글폴더 목록이 보이지도 않았습니다.

테스트 결과 마운트되는 영문폴더명 하위에 한글폴더가 있을 경우
폴더명이 한글로 정상적으로 보이고 정상적으로 이용이 가능합니다.
제일 처음 접속했을 시 최상위 공유목록의 한글폴더명만 깨지는 듯 합니다.

아래는 9.04 버전에서 지금껏 잘 사용하던 화면입니다.

[attachment=1:3zrsumow]Ubuntu_9.04_samba_winshare.png[/attachment:3zrsumow]

원인이 무엇이며 해결방법은 없는 것인지 궁금합니다. ㅠㅠ

제 컴도 하드를 여러 개 나눠서 쓰는데
영문으로 된 이름은 표시가 잘 되는데
한글로 된 들라이브명은 ???로 표시되더라구요.
아마도 9.10의 버그인가 봅니다.
해결책 아시는 분 저도 답변 바랍니다.

https://bugzilla.samba.org/show_bug.cgi?id=6829

[quote="lunatine":2ghyasns]삼바의 버그입니다.[/quote:2ghyasns]

역시 버그였군요.ㅠㅠ
이 문제 때문에 아직 코알라가 제 컴에 매달리지 못하고 있습니다. ;;;
자세하게 설명해 주셔서 너무 감사드려요~
좋은 시간 되세요~ ^^

저도 같은 문제입니다만 한글이 깨지는 부분만 직접입력해주면 그 다음부터는 한글이 제대로 표시 됩니다.
그런후 책갈피에 등록해서 사용합니다.

[code:qxhfvv39]
smb:// 192.168.10.101/공유폴더
[/code:qxhfvv39]

위 처럼 입력하면 제대로 보입니다.

[quote="annalee":iwkpvy22]한글이 깨지는 부분만 직접입력해주면 그 다음부터는 한글이 제대로 표시 됩니다.[/quote:iwkpvy22]

이런 방법이 있었군요. 임시방편으로 사용할 수 있겠습니다.
감사합니다. ^^

[size=150:3ju11g40][color=#FF4000:3ju11g40]이 문제는 이제 업데이트 하시면 해결됩니다.[/color:3ju11g40][/size:3ju11g40]
오늘 업데이트 관리자가 뜨면서 업데이트 목록을 살펴보니…
삼바관련 업데이트가 있었습니다.
혹시? ㅎㅎㅎ 기대를 하고 냉큼 업데이트 했습니다.
위의 삼바공유 최상단에서 한글폴더명이 깨지는 것이 말끔히 사라졌습니다. ^^