Gstreamer0.10.22에서 예제가 안돌아가요

gstreamer0.10.22에서 예제가 안돌아가요
이거 설치하고 나서
tests/examples/helloworld 에서
helloworld를 실행하고싶은대요
./helloworld a.mp3로 실행하면(a.mp3파일은 제가 암거나 넣은거에요)
could not find plugin "mad" 가 뜨는데
mad를 도저히 찾지를 못하겠어요
이거 혹시 아시는분 계실까싶어서 올려봅니다
아시는분들은 좀 갈켜주세용~~
즐건하루 되세요

mad 기반 디코더가 없어서 나오는 에러입니다.
일단 mad 는 ugly set 에 속하기 때문에 ugly 나 mad 가 들어가 있는 gst-plugins 를 설치해 주셔야합니다.
지금 설치 되어있는 플러그인은 아마 gst-inspect-0.10 명령으로 확인이 가능할 겁니다.

지금 리눅스가 아니라 확실한 답변은 못하겠네요. :lol:

gstreamer0.10-plugins-ugly 아마도 이 패키지죠? =33 =33

답변 정말 감사드립니다
그런대요 gstreamer0.10-plugins-ugly가 설치되어있는데
gst-inspect0.10 실행해서 설치된것들 확인하면
mad에 대해서는 없는거 같아요
sudo apt-get install gstreamer0.10-plugins-ugly로 깔면
최신버젼이 이미 설치되어있다고 뜨거든요
정말 어떻게 해야될지 모르겠어용 ㅠㅠ

이런 식으로 확인해 보시기 바랍니다.

[code:2qmxk3r2]gst-inspect-0.10 | grep mad[/code:2qmxk3r2]

[code:2qmxk3r2]gst-inspect-0.10 mad[/code:2qmxk3r2]

libgstmad.so 가 제대로 설치되어 있는지 다음으로 알수 있습니다.

[code:2qmxk3r2]dpkg-query -S /usr/lib/gstreamer-0.10/libgstmad.so[/code:2qmxk3r2]
제 노트북에서는 다음과 같이 결과를 던져주더군요.

[code:2qmxk3r2]gstreamer0.10-plugins-ugly: /usr/lib/gstreamer-0.10/libgstmad.so[/code:2qmxk3r2]
ugly 패키지안에 mad 가 포함되어있습니다.