오픈오피스에서 프린터로 출력을 하는데 한 글자씩 출력이 안됩니다

시스템 : ubuntu-8.10-desktop-i386
워드프로세서 : openoffice.org 2.4
프린터 : EPSON Stylus Photo R210

오픈오피스에서 작업을 하면서 바로 프린트 출력을 하는데 [b:380scvwb]은 바탕체[/b:380scvwb]에서는 [color=#FF0000:380scvwb][b:380scvwb]‘원’[/b:380scvwb][/color:380scvwb]자가 출력이 안되고, [b:380scvwb]은 돋움체[/b:380scvwb]에서는 [color=#FF0000:380scvwb][b:380scvwb]‘리’[/b:380scvwb][/color:380scvwb]자가 출력이 안되는데 같은 경우를 찾을려고 하는데 아무리 찾아도 나오지 않네요.
이거 도대체 어떻게 처리해야 되나요…;;

저도 궁금 해서
글꼴 맞추고 크기 다양하게 해서
테스트 해보니
은바탕체 "은" 은 나오고
[b:3gcrmihl]은돋움체 "리" 는 안나오는 군요[/b:3gcrmihl]
[attachment=0:3gcrmihl]screenshot2.png[/attachment:3gcrmihl]테스트 프린터는 삼성레이저 4500 입니다. hp3820 잉크젯은 잉크없어 테스트 불가 :mrgreen:
신기 한데요 다른분도 테스트 바랍니다.

항상 출력을 pdf로 변환한뒤 출력하기 때문에 이런 문제가 있는지 몰랐네요=_=;; 프린터만 멀쩡하면 테스트를 해볼텐데…

제가 일전에 올린 글입니다. viewtopic.php?f=22&t=2650

사무실에 hp 잉크젯 프린터가 있는데, 여기에서는 정상으로 출력됩니다. 삼성 프린터에서만 문제가 되네요.
이 번에 네이버에서 제공하는 나눔글꼴을 기본 글꼴로 설정하고 똑같이 출력해 봤더니 정상적으로 출력됩니다.

글꼴 문제인것도 같고, 오픈오피스 문제인것도 같은데, 정확히 모르겠네요.
오픈오피스에서만 이런 현상이 나오는데, 같은 글꼴로 다른 프로그램에서 하면 정상으로 나오니 말이죠.

전 OO 2.4 Calc에 Canon MP150에 은 돋움인데 "리"자가 출력이 안 됩니다.

내컴퓨터도 출력이 안되네요. print는 lexmark e120 입니다. 서체 버그같습니다.

epson cx4900프린터로 오픈오피스 스프레드시트(calc)문서를 출력하는데 글꼴을 '나눔고딕 코딩’이나 '나눔고딕’으로 하면
'문’이란 글자가 출력이 안되네요

흠… 저도 지금껏 떠돌이님 처럼 PDF로 프린트를 하다가 해결책을 찾아볼까 하고 글을 올렸는데 역시나 해결이 안되네요.
계속 PDF로 출력을 해야 할 듯… ^^;

저도 우분투 8.10/오픈오피스 3.0 버전에서 은돋움의 '리’자가 출력이 안되는 문제를 확인했습니다. 혹시나 해서 [url=http://kldp.net/projects/unfonts:fmttxkkj]은글꼴 사이트[/url:fmttxkkj]에서 배포하는 은돋움으로 바꿔보니 '리’자도 잘 인쇄됩니다. (대신 새 은돋움은 화면에서 anti-aliasing이 안되는 것처럼 보이네요. 혹시 이 문제에 대한 해결책을 알고 계신 분?)

인쇄가 안되는 것이 특정 글꼴의 특정 글자에서 나타나는 문제이기는 하지만 다른 프로그램에서는 문제가 없으므로 오픈오피스와도 관련된 문제이겠지요? 다른 배포판에서도 확인해서 기회가 되면 개발자에게 문제를 알리도록 하겠습니다.

우분투 8.10 / 삼성 ML-2850 프린터 / 오픈오피스 2.4 우분투 버전 & 3.0 바닐라 버전으로 확인해 보니 나눔고딕에서 '문’자가 인쇄되지 않는 문제는 발생하지 않습니다.

그리고, 페도라 10에서 확인해 보니 은돋움의 '리’자 문제가 발생하지 않습니다. 우분투의 은돋움을 윈도우 비스타에서 사용하는 경우에도 역시 문제가 발생하지 않습니다. 특정 글자가 인쇄되지 않는 문제는 아마 ‘우분투의 은돋움 + 리눅스용 오픈오피스’ 조합에서만 볼 수 있는 아주 미묘한 문제인 것 같습니다.

우분투 8.10 64, 프린터는 HP 데스크젯(잉크젯) 950C 입니다.

오픈오피스 3.0.1 Writer/Calc 에서 은바탕 ‘원’, 은돋움 '리’는 출력 안되고, 나눔고딕/코딩 '문’은 됩니다.
특정 프린터에서 생기는 문젠 아닌가보네요.

네이버 사전체는 "전"자가 인쇄가 안 되네요.

저는 윈도우 바탕 글꼴 ‘창’ 자가 인쇄가 안 되네요.
이거 정말 해결책이 없는 걸까요.
(저는 우분투 9.04 / 오픈오피스 워드 3.0 / 프린터기는 HP 레이저젯 5100 / 캐논 Image Runner 3300)
그런데 두 프린터기 모두에서 ‘창’ 자가 인쇄되지 않는 것으로 보아 프린터기 문제는 아닌 것 같습니다.
또한 PDF 인쇄는 잘 되는 것으로 보아, 오픈오피스 문제도 아닌 것 같다는 게 제 추측입니다.
우분투의 프린트 드라이버에 뭔가 문제가 있는 것 아닐까요?

저도 이런 경험 많이 하였습니다. 오픈오피스 라이트에서 정상적으로 화면상으로 보였는데…
출력하니 글자들이 종종 빠지는 겁니다. 저는 HP 레이저젯1000을 사용합니다.
그래서 그 후에는 오픈오피스의 pdf출력 기능을 사용하여 출력을 하고 문서보기도
Okular를 통해서 열어봅니다. 특별히 수정이 필요하지 않은 경우에는 이렇게 사용합니다.

[url:1q410kiv]http://openoffice.or.kr/forums/viewtopic.php?p=9413[/url:1q410kiv]
몇 가지 테스트한 결과가 있습니다. 해결책은 아니지만 실마리를 잡을 수 있는 자료 아닐까 해서 썼습니다. 한 번 봐주세요.

어… 저 가끔 프린팅 할때 이런 적이…(없는데;)

[quote="mytory":xuso8bna][url:xuso8bna]http://openoffice.or.kr/forums/viewtopic.php?p=9413[/url:xuso8bna]
몇 가지 테스트한 결과가 있습니다. 해결책은 아니지만 실마리를 잡을 수 있는 자료 아닐까 해서 썼습니다. 한 번 봐주세요.[/quote:xuso8bna]
정말 그럴까? 하고 테스트 해 보니…
똑같은 현상이네요.
오픈수세에서 문제가 없다면 우분투의 문제인가요?

다시 같은 문서를 나눔고딕으로 인쇄해 봤더니
은바탕에서 안 나오던 글자가 나오고
나오던 글자가 안 나옵니다.

아마도 글꼴마다 안 나오는 글자가 다른 것 같네요.

우분투 9.04
오픈오피스 3.1.1
삼성 ML2010R

비스타는 첫장만 인쇄해 봤는데 이상없군요…

프린터 드라이버의 문제나 글꼴의 문제라면, PDF 문서를 만들어서 evince를 통해 인쇄를 해보시면 어떨까요?

오픈수세나 다른 배포판에서 문제 보고가 없는 이유는… -_-; 이런 말하기 뭐하지만 우분투 쪽이 한글 쪽에서는 좀 더 다양한 환경에서 많이 사용되기 때문이 아닐까 싶습니다.

혹시 갑자기 드는 생각이지만 우분투에서 제공하는 오픈오피스의 문제가 아닐까 싶기도 합니다. 우분투에서는 오픈오피스의 향상 버전인 go-oo를 사용합니다. 즉 오픈오피스에서 제공하는 버전과 약간 다릅니다.(오픈오피스 정보에도 Debian and Ubuntu에서 만들었다고 나와있죠)

제가 테스트할 수 있는 환경이라면

  1. 우분투의 오픈오피스를 지우고,
  2. 오픈오피스 커뮤니티에 있는 3.1.1 DEB 패키지를 받아서 설치 후
  3. 인쇄를 해본다

하는 방식으로 테스트를 해볼텐데…=_=; 집에 프린터가 다 망가진 상태라… 불가능하네요;;

[quote="떠돌이":33x7rczj]집에 프린터가 다 망가진 상태라… 불가능하네요;;[/quote:33x7rczj]
CUPS-PDF를 설치하고 PDF로 저장을 하면 프린터로 인쇄할 때와 마찬가지의 증상이 나타나므로 프린터 없이 문제의 증상을 확인할 수 있습니다.

개발자에게 문제를 보고한 적이 있으나 재현할 수 없는 문제로 처리 종료되었습니다. 오픈수세에서는 문제를 재현할 수 없다고 하더군요. 자세한 내용은 아래를 참고하시기 바랍니다.

http://www.openoffice.org/issues/show_bug.cgi?id=102459

페도라나 수세 리눅스에서 문제가 발생하지 않는 것을 보면 확실히 우분투와 관련한 문제인 것 같습니다.